More Information

On 29 December 2018, we will upgrade to Transport Layer Security (TLS 1.2) for necessary improvements to your online security.

If your web browser does not support TLS 1.2 by 29 December 2018, you will not be able to access iOCBC. This web page shows you what to do if your web browser does not support TLS 1.2.

What is TLS and why you should care

Transport Layer Security (TLS) is an encryption standard that provides privacy and data security between our database and web servers and the web browsers you use through your device. We use it to protect you whenever you visit iOCBC.

For TLS 1.2 to work on your device, both your operating system and web browser must support it. You may refer to the system requirements for iOCBC online trading here.

What if my web browser does not support TLS 1.2

If your web browser does not support TLS 1.2 from 29 December 2018, you will not be able to view any of our web pages nor access iOCBC. Instead, you will see an “Error 404” message.

Does TLS 1.2 only apply to iOCBC

In line with the OCBC Group standards and so as to provide our customers with secure and reliable online trading services, we are requesting all our customers to have their web browser ready now for TLS 1.2. This would bring iOCBC in line with market standards.

What if I still cannot access iOCBC

If your web browser appears to be ready for TLS 1.2 but you still cannot access iOCBC, please ensure your web browser is not running in legacy mode.

Call us

1800 338 8688

(or +65 6338 8688 if you are calling from overseas)